Skip to content
The latest version of DbVisualizer was released 2024-03-11DOWNLOAD HERE ->

Opening a Tab

Database tree objects

You can open an object by double-clicking on the object node, or by pressing Enter with the node selected, in all navigation tab trees. This opens either an Object View tab or an SQL Commander tab, depending on the object type: database object or script.

By default, a database object is opened in an Object View tab that is "available," meaning it is not pinned, busy running a task, or contains pending edits. The current tab is chosen if it is available, otherwise any other available tab is used. If none of the tabs is available, a new tab is created for the object. You can change this behavior in the General/Tabs category in Tools->Tool Properties, so that a new tab is always used instead of using an available tab.

If a tab is already open for the object, it is made the active tab. An alternative to double-clicking a database object is to use the Open in Tab choice from the node's right-click menu. Open in Tab is also available in the Open Object drop-down menu button in the Databases tab toolbar.

If you want to open a database object in a new tab instead of an available tab, hold down the Alt key when you double-click the node, use the Open in New Tab choice from the node's right-click menu or from the Open Object drop-down menu button in the Databases tab toolbar. The drop-down button keeps the last choice as the default, so once you have selected Open in New Tab once, you only need to click the button to do the same.

Both Open in Tab and Open in New Tab can also be used when multiple nodes are selected in the tree to open multiple tabs in one go.

To replace the content in a specific Object View tab with information for another object, drag the node for the new object from the object tree and drop it on the Object View tab header.

The behaviour when double clicking a Database object can be configured in Tools->Tool Properties and in General / Database Objects Tree.

Scripts and Monitors

Scripts (Bookmarks and Monitors) are always opened in a new SQL Commander tab unless the script is already opened in a tab. If so, that tab is activated instead. An alternative to double-clicking the node is to use Open in SQL Commander in the right-click menu or the corresponding button in the Scripts tab toolbar. The right-click menu also holds an Open in SQL Commander and Execute choice.

A new, empty SQL Commander tab is created by clicking the Create SQL Commander button in the main toolbar or using the corresponding File menu item. You can use this kind of SQL Commander tab for ad-hoc statement execution or to create a new script.

SQL Commander tabs can also be opened for files in the file system. Click the Open File button in the main toolbar or choose File->Open to open the file chooser window and select one of more files. Alternatively, you can drag files from your platform's file browser and drop them in the main toolbar area.

In addition see also Synchronizing object tab selection and selection in the tree which shows how to set up DbVisualizer to automatically select the database tree node when the corresponding object view tab is selected and vice versa.

Only in DbVisualizer Pro

Multiple SQL Commander tabs are only available in the DbVisualizer Pro edition.